Q: What operating system do I need to access your Axis 360 eBooks?

You need iOS 7.0 or higher, Android 4.2 or higher or Windows Version 8 or higher.  Some older devices may not allow you to update the operating system to these requirements.

Last Updated: Oct 26, 2017     Views: 317
Answered By: Melody K